Foro bicicletas eléctricas, Kits eléctricos y baterías


No estás conectado. Conéctate o registrate

Foro bicicletas eléctricas, Kits eléctricos y baterías » Controlador, accesorios, manetas con corte, acelerador... » ***Cycle Analist V3*** - Tutoriales / Información -

***Cycle Analist V3*** - Tutoriales / Información -

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

meao

avatar
Bueno, pues abro este hilo para poder mantener tutoriales e informacion sobre el Cycle Analist V3 junto.

Para empezar, hay que diferenciar las dos versiones existentes del mismo:

- CA3-DP
- CA3-DPS

Es el mismo aparato, la unica diferencia entre ellos es el metodo en que mide la velocidad. Y estan pensados asi para funcionar con motores DD o con motores con reductora. En este caso, el CA3-DP usa los sensores Hall del motor para tomar la medicion de la velocidad de la rueda. Mientras que el CA3-DPS tiene un sensor externo.

Asi pues, aprovecho a colocar el primer tutorial. En mi caso, compre un CA3-DPS en la tienda del banner y lo voy a usar con un motor DD(9C 7x9), asi que para eliminar cables, me he liado a quitar el sensor externo que trae y recablear para que tome la medicion de los sensores del motor.

Aqui os pongo unas fotos y el proceso:

Paso 1: Apertura del Cycle Analist.

Es muy sencillo, solo hay que retirar 4 tornillos que trae y separar las dos partes de la carcasa.



Hay que tener cuidado de soltarlas despacito, para no dañar el "cable" que conecta los botones de la pantalla al modulo principal. Asimismo, entre la base y la placa, hay unas arandelas de goma que van en los tornillos, que sirven de aislante frente al agua y como silentblock a la placa.



Paso 2: Identificar y eliminar el sensor de velocidad externo.

No hay mas que seguir el cable del sensor de velocidad externo y desoldarlo de la placa. El cable esta compuesto por dos hilos con funda de color rojo y conectados a la placa principal en "G" y "SP".







Paso 3: Localizar y soldar el cable que recibe la señal de los sensores del motor.

Para ello, los controladores compatibles con las nuevas versiones de Cycle Analist, toman la señal de uno de los sensores del motor y la mandan a traves de el cable amarillo del conector del CA. En prevision, este cable viene en el mazo, colocado en espera de usarlo. Solo hay que soltarlo del termoretractil que lo asegura y soldarlo en la placa principal en el alojamiento que antes desoldamos y ponia "SP".





Y ya esta. Ahora, el CA, tomara la señal para calcular la velocidad de uno de los sensores Hall del motor. Solo habra que configurar en el menu el numero de polos del motor para que haga la lectura correctamente.
En caso de tener la version CA3-DP, y querer un sensor externo, no hay mas que invertir el proceso.

Saludos, Carlos.

meao

avatar
Bueno, siguiendo con las modificaciones, os muestro como modificar el voltaje de salida del conector para el PAS/Sensor de PAR, originalmente es de 10v, y yo lo voy a poner a 5v.
Esto es porque los sensores de PAR trabajan a 10v y los sensores de cadencia o sensores de cadencia y direccion trabajan a 5v.
Pero no solo eso, sino porque hare una segunda modificacion que ya os enseñare, en la que podre tener un selector para ajustar la potencia de la ayuda al pedaleo sin usar el conector externo dispuesto para ello(ya que lo usare para seleccionar varios niveles de potencia del acelerador).

Unico Paso: Cambiar cable de +10v a +5v.

Pues sencillo es, no hay mas que localizar el cable blanco del conector para el PAS del CA y desoldarlo de su ubicacion original(10v) y soldarlo en alguno de los pads de la placa libres que tengan la nomenclatura +5v.





Espero que os sea util.

Saludos, Carlos.

Sebibike

avatar
aplauso  Puesto como Post-it


_________________



Blogs especializados
http://Bici-electrica.blogspot.com
http://Bicicleta-electrica.blogspot.com

Arbol


Me suscribo. Como me gustaría aprender a tener facilidad en hacer esas cosas.

jimwebo

avatar
Si señor.
Así da gusto.
Por cierto,tuviste algún problema para poner el valor del shunt?
Porque mi controlador no pone el valor y me estoy volviendo loco.
Un saludo

meao

avatar
jimwebo escribió:Si señor.
Así da gusto.
Por cierto,tuviste algún problema para poner el valor del shunt?
Porque mi controlador no pone el valor y me estoy volviendo loco.
Un saludo
Aun no lo tengo instalado, le estoy haciendo las modificaciones antes de instalarlo.
Hay varias formas de averiguar el valor del shunt si no dispones de el. En Endless hay un manual muy util, ahi vienen diferentes formas de averiguarlo. A ver si lo traduzco y lo pongo por aqui.

Saludos, Carlos.

emenege

avatar
iv9x94

Bici Electrica Mallorca

avatar
¡Qué nivel!
Me suscribo al "post it".

meao

avatar
Pues por aqui os pongo unas fotillos y unas explicaciones de como simular un sensor de par a partir de un sensor de pedaleo estandar para poder dejar libre el puerto auxiliar del CA para otras funciones.

He seguido el esquema que indican en el manual que se han trabajado en Endless Sphere.



Y como he usado un sensor de pedaleo normal, lo he conectado de la siguiente manera:



Un sensor de pedaleo normal, lo que hace es indicar al controlador, mediante pulsos, las revoluciones del pedaleo. Los mas modernos y comunes, tambien indican la direccion de giro. Para ello, en el sentido de giro adecuado mandan pulsos de +5v y si lo hacemos en el sentido contrario, pulsos que no llegan a ese voltaje. De esta manera, el controlador no activa la ayuda si pedaleamos hacia atras.

Asi pues, como indico en la foto superior, el sensor tiene 3 cables. Uno recibe el +5v, otro la masa(con estos dos activa el sensor), y otro que manda de retorno la señal al controlador para indicarle que ocurre con los pedales.
Pues bien, +5v y masa van a su sitio en el conector del CA(ojo, primero se debe cambiar internamente el cable de alimentacion ya que por defecto viene a+10v), mas tarde, tomamos el cable de señal y lo duplicamos para poder conectar en los pines del CA que reciben las RPM(revoluciones) y DIR(Direccion).
Hecho esto, solo hay que añadir los dos potenciometros en los cables para poder simular la presion que se ejerceria en los pedales y que el CA sepa cuanta potencia ha de dar por cada pedalada.
Mas tarde, se ha de configurar el CA en modo sensor de par(torque sensor). Para ello hay que seguir unas tablas que se aportan en el manual de ES y que no me he acordado de tomar para poner aqui, para seleccionar el rango de potencia que se aplicara en funcion de las revoluciones del pedaleo y la posicion del potenciometro.

He de decir que funciona correctamente. Salvo que, dadas mis conexiones, el CA recibe al pedalear marcha atras, tambien pulsos, que no son de +5v, pero que se le acercan mucho, y no discrimina estas señales, con lo que al pedalear hacia atras tambien se activa. Tengo que mirar si mediante la programacion del CA puedo hacer algo al respecto. Pero de momento, la verdad es que no me ha interferido en un uso normal.

Asi es como me ha quedado:











Para fijarlo, he doblado un trozo de PVC, lo he recubierto con un trozo de una camara pinchada y lo he pegado a la pantalla del CA con velcro Dual Lock de 3M. De esto no tengo fotos, pero en el video de la prueba del infineon de 12FET a 75v se puede ver colocado.

Saludos, Carlos.



Última edición por meao el Dom Jun 01, 2014 11:41 pm, editado 1 vez (Razón : corrijo fotos)

bataanjr


Leyendo del CA vi que hay una versión normal y una HC y averiguando que es ley que aunque el controlador tenga la conexión si tiene mucho amperaje puede fundir el normal y la pregunta es cual es el máximo amperaje que soporta el normal.

meao

avatar
bataanjr escribió:Leyendo del CA vi que hay una versión normal y una HC y averiguando que es ley que aunque el controlador tenga la conexión si tiene mucho amperaje puede fundir el normal y la pregunta es cual es el máximo amperaje que soporta el normal.

No, no puede fundirlo porque por el CA no pasa la corriente que va al controlador.

Hay un Shunt externo, pero es para usar si el controlador no viene preparado para conectar directamente el CA. Segun fabricante, el shunt externo es capaz de funcionar hasta 50a, y si se quiere usar con mas chicha hay que ponerle una placa disipadora o similar.

Asi que, no te preocupes por tu CA, el solo mide la caida de tension entre dos puntos concretos del circuito que tiene una determinada resistencia, y de ahi saca la corriente que pasa.

Saludos, Carlos.

bataanjr


OK gracias. Pero no lo tengo todavía y es que lo mas de todas las cosas que ase lo mas que necesito es lo de velocidad con el motor y el ajuste del LVC. Porque como lo mío es todo a 100% las demás cosas que ase es bajar potencia eso creo.

bataanjr


Esto es lo que me creo la duda.
http://www.ebikes.ca/shop/ebike-parts/cycle-analysts/ca-hc.html

Dsoldevilla


Estaba siguiendo este post, y ahora que he recibido mi CA, me dispongo a conectarlo, pero tengo problemas, mi controlador es un Lyen, y no hay manera que funcione el acelerador, estoy atascado en el principio, he probado a conectar todos los cables como vienen, nada, cortando el cable del controlador, y tampoco, pero si saco el cable de señal directo del acelerador conector del acelerador si funciona.

Alguna idea?

Tambien he probado todas las configuraciones que se me han ocurrido en el software del CA y nada . . .

Gracias, Un Saludo.

meao

avatar
Seguramente, el controlador de Lyen lleve conexion para la version de CA anterior a la V3.
Prueba a sacar el cable verde del conector del CA y conectarlo directamente al conector del controlador donde iria el acelerador(solo al cable de señal, que suele ser blanco o verde).

Saludos, Carlos.

Dsoldevilla


Ok, leido y comprobado, resultado: Perfecto!!!!!

Muchas gracias, voy a ver si sigo configurando el CA3, volveré a preguntar mas cosas, que hay MUCHO para configurar,

Un Saludo.

meao

avatar
Me alegra, ahora a disfrutar de sus funciones.

Aprovecho a avisar que ha salido una nueva version de Firmware, la P13, con alguna novedad interesante. En el canal de youtube de Grinn hay un video con Justin explicando las novedades.

Saludos, Carlos

Dsoldevilla


Hola buenas, voy a seguir preguntando . . . 
Mi controlador viene con una pegatina que indica 1.33 de shunt, pero lo pongo en el CA, y me sigue marcando uno 15-25w en negativo, ¿esto como se corrije?
Y otra duda, la señal del freno, tambien la debería mandar por el cable de señal al controlador, pero tengo activada la frenada regenerativa, y nada . . . estoy pensando en mandar los dos hilos de freno al controlador.

Un Saludo.

jimwebo

avatar
Hola en cuanto a lo de la frenada regenerativa,no te puedo ayudar.
Pero esa medida en negativo puede que se arregle con la opción ZEROAMPS,le dás y pone el amperímetro a 0.
En ocasiones cuando el equipo está frío tambien me dá una pequeña medida en negativo o en positivo.
Un saludo.

oriam

avatar
Zero-Amps como te comenta Jimwebo, establece ese punto como cero amperios para empezar a tomar las lecturas.


Zero-Amps: Pressing the button here will take the present amperage readings as the “zero amps” reference. After holding the button, you will see two voltages on the screen which are the outputs of the two current amplifiers. They should both be around 2.5V.


_________________


http://www.enbicielectrica.com

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.