Foro bicicletas eléctricas, Kits eléctricos y baterías


No estás conectado. Conéctate o registrate

Foro bicicletas eléctricas, Kits eléctricos y baterías » Probando kits y bicis eléctricas a fondo » Intentando reprogramar mi bafang...

Intentando reprogramar mi bafang...

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1 Intentando reprogramar mi bafang... el Mar Oct 11, 2016 9:17 pm

Hedumaza

avatar
Bueno, esta tarde me he puesto a despiezar la bici, pues dentro de unos días tengo proyectado comprar la bici nueva y quiero tener todas las partes que voy a trasplantarle a la nueva bici, ya preparadas.
El caso es que me he decidido a reprogramar el motor, He confeccionado los cables, los he conectado al conector macho verde de la pantalla... tal como indica esta imagen que me he bajado de una web... creo que de un foro francés.



y tal que así he conectado los cables al conector del controlador. De igual manera los he conectado al USB que compré. Previamente he cargado el controlador del conector usb en el portatil, el cual tiene windows 7, he instalado el programa Controller y lo he ejecutado, he conectado el usb al portatil, y me ha aparecido en   NETWOK PORT : COM3, que es el puerto que le ha asignado el ordenador al conector usb
En el apartado BANDRAKTE : me marca 1200.
Le pulso en la opción CONNECT, y se active el pulsador CLOSE, que hasta ese momento no se podía seleccionar. el caso es que... la aplicación ya no hace nada más, los pulsadores READ y WRITE se quedan clareados y no tengo opción a pulsar sobre ellos...
He probado a desmontar el cable y a volverlo a conectar, cable a cable, pero el resultado es el mismo... el ordenador me reconoce el conector USB, pero la aplicación no hace nada... ¿ qué es lo que estoy haciendo mal ?
Necesito vuestro asesoramiento.

2 Re: Intentando reprogramar mi bafang... el Mar Oct 11, 2016 10:20 pm

meao

avatar
Has ejecutado el programa en modo Administrador?.

3 Re: Intentando reprogramar mi bafang... el Miér Oct 12, 2016 12:07 am

jimwebo

avatar
Ese mismo cable es el que se usa para programar controladores lyen, en mi caso sólo fui capaz desde Windows XP.
Un saludo.

4 Re: Intentando reprogramar mi bafang... el Miér Oct 12, 2016 12:14 am

eperezat


Yo no recuerdo bien y el ordenador donde lo tenia me ha petado, pero creo recordar que has de cargar un archivo de parametros antes.

5 Re: Intentando reprogramar mi bafang... el Miér Oct 12, 2016 3:55 am

Hedumaza

avatar
meao escribió:Has ejecutado el programa en modo Administrador?.

pues no he caído en ese detalle, mañana probaré? 

jimwebo escribió:Ese mismo cable es el que se usa para programar controladores lyen, en mi caso sólo fui capaz desde Windows XP.
Un saludo.

el cable que estoy usando no es como el de la imagen, la imagen me ha servido de guía para saber donde tenía que conectar cada cable.

El cable lo he confeccionado con los cables de un viejo ordenador que tenía son los cables que van del frontal de la caja a la placa.
este es mi cable...




eperezat escribió:Yo no recuerdo bien y el ordenador donde lo tenia me ha petado, pero creo recordar que has de cargar un archivo de parametros antes.

he probado a cargar la configuración de kepler, como me recomendarte, pero no me la ha cargado... es que no ha hecho nada.

A ver, estos son los pasos que he dado tras preparar el cable...
He conectado cada cable según el esquema de la primera imagen.
he conectado el usb al puerto del ordenador, y lo ha reconocido.
he ejecutado la aplicación, y ha cargado el puerto.
he encendido la batería.
le he pulsado sobre la opción... la que hay debajo del indicador de puerto... es que estoy escribiendo desde el móvil... y no me acuerdo como se llama esa opción.
y ya no hace nada más...
he reconectado los cables, he reconectado la batería... incluso he cambiado el puerto, ya que el usb me lo reconoce como COM3 y lo he cambiado a COM4, pero ni con esas.
Mañana volveré a probar como administrador y cargando una configuración, pero antes me pasaré por aquí, por si algo de lo que he hecho no estuviera bien.



Última edición por Sebibike el Miér Oct 12, 2016 12:19 pm, editado 1 vez (Razón : A ver)

6 Re: Intentando reprogramar mi bafang... el Miér Oct 12, 2016 8:19 am

Hedumaza

avatar
Tras llegar a casa del curro, lo he vuelto a intentar, incluso reinstalando el driver, pero no consigo nada.
he hecho alguna prueba, si giro los pedales, el motor se activa, y la luz del sensor de velocidad ( el pilotito rojo ) está encendido. Todo esto con los cables conectados al conector usb, y este, a su vez, al ordenador con la aplicación ejecutándose, esta vez como administrador... y no hace nada, no aparece la información del controlador ni nada que haga sospechar que el ordenador y el controlador se están comunicando.
Sospecho que el culpable va a ser el conector usb, el cual, al conectarlo al ordenador se le enciende un pilotito rojo, pero se queda fijo. En otra ocasión en que lo he conectado, se le han encendido dos pilotitos rojos, pero en esa ocasión, la batería estaba apagada, al encenderla, ese segundo pilotito rojo se ha apagado y ya no ha ocurrido nada nuevo... todo a continuado igual.
He realizado unas mediciones de voltaje en los extremos de los cables, y no se si los resultados arrojarán algo de luz, pero esto es lo que el medidor me a dado...

En el conector USB :

gnd + rxd > 3,66 v.
gnd + txd > 3,66 v.

CONTROLADOR :

grd + rxd > 4,60 v.
grd + txd > 4,58 v.

Por tanto, ahora se que la culpa no es de los cables, ni de la conexión de estos al conector del controlador, ya que me he asegurado muy mucho de conectarlos correctamente... no me haría ninguna gracia freir el controlador.

Tambien me he asegurado de conectar los cables en el orde adecuado en el conector usb... pero por alguna razó que se me escapa... el ordenador no se entera de lo que le dice el controlador...
 ¿ Quizás el conector USB no sea el adecuado ?... en un lado del conector USB aparece esta información :

" USB-TTL
USB-STC-ISP "

7 Re: Intentando reprogramar mi bafang... el Miér Oct 12, 2016 8:01 pm

Hedumaza

avatar
Estoy por tirar la toalla... llevo tooooda la tarde dándole vueltas, instalando y desistalando distintas aplicaciones, conectando y desconectado los cables, desitalando y reistalando montones de controladores el usb-ttl... creo que el problema es que el usb-ttl que he comprado no vale, hasta ahora, la mayoría de las web por las que he buscado información usan un usb-ttl de 6 conectores, el mios es de 5 lo que me hace sospechar que el modelo que tengo no sirve. En agunos sitios hablan de un usb-ttl, con funcionamiento a 5v ( modulo CH340G ), el mio funciona a 3v... voy a intentar localizar uno de 5v. en alguna web española...
Por cierto, ¿ sabríais donde se puede comprar el cable de reprogramación aquí, en la UE ?

8 Re: Intentando reprogramar mi bafang... el Miér Oct 12, 2016 10:14 pm

eperezat


Yo lo compre en Ebikes components.

9 Re: Intentando reprogramar mi bafang... el Jue Oct 13, 2016 9:14 pm

Hedumaza

avatar
eperezat escribió:Yo lo compre en Ebikes components.

Gracias Eperezat, voy a ver si puedo compar el cable, pues he tirado la toalla con el conector usb... esta tarde he desmontado los cables, los he soldado y los he aislado a conciencia, más de media hora perdida preparando 4 cables de mierd*, he seguido los pasos incicaban en el foro americano, pues al parecer había un usuario al que le había pasado lo mismo que a mi, con el mismo conector USB-TTL que el mio... y al final, tras los consejos que le han dado, a conseguido, al menos, hacer que el ordenador y el controlador se comunicases... pero en mi caso no ha cambiado nada... ya estoy aburrido... he llegado incluso ha pensar en que me hayan vendido un motor con un controlador " capado "... pero no creo que vayan por ahí los tiros, así que desisto de reprogramar el motor con el conector USB-TTL que tengo, me da que tanto está llevo el cántaro a la fuente... que voy a terminar quemando el controlador con tanto conectar y desconectar los cables.
Voy a intentar comprar el cable... y que sea lo que el Bafang quiera.

10 Re: Intentando reprogramar mi bafang... el Jue Oct 13, 2016 9:43 pm

Hedumaza

avatar
No encuentro la web que me dices Eperezat.
He tirado de lupa para poder leer la información del chip del USB-TTL que tengo... en el chip pone PL-2303HX, y debajo un código " LF ( o LP... es que casi no se ve ), 13209A
Por el chip, creo que debería de servir para reprogramar el bafang, pues es el tipo de chip que se suele usar... lo que no entiendo es que no logro que se comunique el portatil con el bafang... en el portatil tengo windoes 7 enterprise... pero he encontrado este hilo publicado en el foro, en el cual Ihupyn reprograma el bafang con un usb con el mismo tipo de chip... solo que él usa un equipo con windows XP y conecta los cables directamente al conector que sale del motor.
Yo he probado haciendo que windows 7 ejecunte la aplicación CONTROLLER ejecutándose con compatibilidad windows xp servi pack 2... pero no he logrado nada... me estoy incluso planteando la posibilidad de instalar el windows xp en el portatil y probar a ver que ocurre, peroooo por otro lado, es una putadita instalar un SO ya absoleto, que hace mucho que no uso, y que luego no consiga nada... eso es lo que me hace dudar... aunque siempre lo puedo instalar en una partición y, si no consigo nada, formatear esa partición Rolling Eyes



Última edición por Sebibike el Lun Oct 23, 2017 12:15 am, editado 1 vez (Razón : A ver)

11 Re: Intentando reprogramar mi bafang... el Jue Oct 13, 2016 9:51 pm

Hedumaza

avatar
Hedumaza escribió:No encuentro la web que me dices Eperezat.
He tirado de lupa para poder leer la información del chip del USB-TTL que tengo... en el chip pone PL-2303HX, y debajo un código " LF ( o LP... es que casi no se ve ), 13209A
Por el chip, creo que debería de servir para reprogramar el bafang, pues es el tipo de chip que se suele usar... lo que no entiendo es que no logro que se comunique el portatil con el bafang... en el portatil tengo windoes 7 enterprise... pero he encontrado este hilo publicado en el foro, en el cual Ihupyn reprograma el bafang con un usb con el mismo tipo de chip... solo que él usa un equipo con windows XP y conecta los cables directamente al conector que sale del motor.
Yo he probado haciendo que windows 7 ejecunte la aplicación CONTROLLER ejecutándose con compatibilidad windows xp servi pack 2... pero no he logrado nada... me estoy incluso planteando la posibilidad de instalar el windows xp en el portatil y probar hña ver que ocurre, peroooo por otro lado, es una putadita instalar un SO ya absoleto, que hace mucho que no uso, y que luego no consiga nada... eso es lo que me hace dudar... aunque siempre lo puedo instalar en una partición y, si no consigo nada, formatear esa partición Rolling Eyes

se me ha ocurrido meter en el buscado el código del chip, el que empieza por LF... y me ha salido un manual para el chip PL-2303HX de Prolific... el mismo que ha creado el controlador para este chip. Viene los S.O. en los que puede funcionar... y al parecer, como windows superior... marca al windows XP... no dice nada de windows superiores al XP, por lo que me parece a mi que el usb que tengo no es compatible con windows / ( aún menos con el de sobremesa, donde probé por primera vez... con windows 8.1 ).
Voy a liarme la manta a la cabeza y voy a instalar el XP en una de las particiones del disco duro... y a ver qué ocurre... ya os contaré... pero parto de la base de que no guardo muchas esperanzas.

Este es ek manual del chip PL-2303HX



Última edición por Sebibike el Lun Oct 23, 2017 12:16 am, editado 2 veces (Razón : A ver)

12 Re: Intentando reprogramar mi bafang... el Vie Oct 14, 2016 10:24 pm

Hedumaza

avatar
Desisto, definitivamente no reprogramo una mierd*
He terminado... harto no, lo siguiente, de intentar reprogramar el motorcito de los coj*n*s, he probado incluso con windows XP, que me ha tocado desempolvarlo e instalarlo en una partición... no hay forma, este bafan me la tiene jurada.
Con lo facil que parece cuando lees a los demás como lo han hecho... y yo llevo dos días ( mañana y tarde )... poniendo y quitando cables, estañando cables, encintándolos bien para evitar cortocircuitos, intalando y desistalando controladores para el puñetero conetor usb... he probado en tres plataformas... Windows 8.1, windows 7 y windows XP, he usado dos aplicaciones para reprogramar el motorcito de marras, una de ellas es de uno que, al parecer a retocado y mejorado la aplicación para eliminar posible errores de ejecución, así como tener que ejecutarla como administrador... y no he conseguido nada... mi bafang no se entera o no se quiere enterar, porque con tanto trajinar con el conetor USB, me he dado cuanta de que el ordenador sí intenta comunicarse con el controlador a través del conector usb... si pongo un puerto distinto, en la aplicación, al que el S.O le ha asignado ( comprobado en el administrador de sistemas ), da error de conexión, pero si pones el mismo puerto... la aplicación se queda esperando a que le llegue información... que nunca le llega.
El conector USB lleva varios " pilotitos ", siempre, al conectarlo al puerto usb de cualquier equipo ( he probado en tres... el sobremesa, el portatl y el notebook ), se enciende un pilotito rojo que siempre permanece encendifo y fijo... en alguna que otra ocasión se a iluminado otro de los tres supuestos pilotitos que lleva, pero se ha apagado en cuanto he encendido la batería, quedando solo el piloto rojo fijo encendido... y nunca pasa nada más... estoy ya aburrido, he tirado los cablesa la basura y voy a pasar de reprogramar el motor... al menos de momento... quizás más adelante, cuando encuentre un sitio donde poder comprar el cable de marras... quizás entonces me decida volver a intentarlo.

13 Re: Intentando reprogramar mi bafang... el Vie Oct 14, 2016 10:56 pm

eperezat


Lo siento pero no se que mas puedo decir para ayudarte.

14 Re: Intentando reprogramar mi bafang... el Sáb Oct 15, 2016 12:18 am

eperezat


Como te dije me peto el otro pc, donde tenia el soft.

Y despues de ver tus problemas, me he decidido a probar el mio con windows 10

Y sin problemas.

Yo al cable que compre le quite la parte usb y puse un convertidor de ftdi que suelo usar para otras cosas.

Me he bajado el driver de ftdi, lo he instalado, me ha detectado el com3, he arrancado el programa, he puesto com3 en la casilla,  le he dado a conectar, y ha detectado el bafang sin problemas,

He modificado un pelo el acelerador y me lo ha cogido.

Has usado un driver usb-ttl de 5 voltios no ? No ha de ser rs232
Y has conectado cruzado los cables. El cable de rx al tx y el de tx al rx

Si es asi te deberia funcionar.

15 Re: Intentando reprogramar mi bafang... el Sáb Oct 15, 2016 1:55 pm

Hedumaza

avatar
eperezat escribió:Como te dije me peto el otro pc, donde tenia el soft.

Y despues de ver tus problemas, me he decidido a probar el mio con windows 10

Y sin problemas.

Yo al cable que compre le quite la parte usb y puse un convertidor de ftdi que suelo usar para otras cosas.

Me he bajado el driver de ftdi, lo he instalado, me ha detectado el com3, he arrancado el programa, he puesto com3 en la casilla,  le he dado a conectar, y ha detectado el bafang sin problemas,

He modificado un pelo el acelerador y me lo ha cogido.

Has usado un driver usb-ttl de 5 voltios no ? No ha de ser rs232
Y has conectado cruzado los cables. El cable de rx al tx y el de tx al rx

Si es asi te deberia funcionar.

este es uno de los controladores que he instalado

he conectado GND > GND, RX > TX, TX > RX, PL> P+
El chip del usb es del model PL-2303HX, que al parecer funciona a 3 y 5 voltios

los pasos que he seguido...
1º he instalado el controlador del usb.
2º he conectado el usb y lo ha reconocido, asignandole un puerto COMx ( verificado en admin. de dispositivos ).
3º he desconectado el usb del portatil
4º he conectado tres cables al usb ( negro a GND, verde a RX y blanco a TX... los conectores 3v y 5v los he dejado libres ).

Cogiendo el conecto macho ( verde ) que conecta el computador al motor, y partiendo en sentico contrahorario desde el tope guia de conexión del macho-hembra...

5º he conectado el cable negro ( GND ) a GND, pin 1.
6º he conectado el cable verde ( RX ) a TX, pin 2.
7º he conectado el cable blanco ( TX ) a RX, pin 4
8º por último he puenteado con un cable, en el conector verde, P+ ( pin 3 ) con PL ( pin 5 ).
9º he reconectado el usb al ordenador, lo ha vuelto a reconecer... se enciende un pequeño led en rojo, con luz fija.
10º conecto la batería ( la enciendo ).
11º inicio el programa ( como administrador )
12º el puerto ya me lo carga directamente, y no me da opción a elegir otro puerto, pero el puerto que carga coincide con el asignado por el ordenador al conector usb.
13º pulso en la opción CONNECT.
14º se activa la opción DISCONNECT
15º ya no sucede nada más, no aparece ningun tipo de dato en la pantalla de la aplicación, el led rojo sigue encendido, el conector usb lleva, greo que 6 led, 3 en la pate de los cables y tres en el lado del conector usb macho, pero solo permanece encendido un led rojo fijo en el lado de los cables.

esta situacion se repite siempre, indistintamente del equipo que use, indistintamente del S.O. que use ( he probado en W8.1,W7 y WXP ), da igual si la aplicación la ejecuto como administrador o no, pero el resultado es siempre el mismo.
incluso he hemulado el WXP en W 8.1, con total funcionalidad... y el resultado ha sido el mismo.
He instalado el WXP en una partición del HDD del portatil, y al final, el resultado ha sido el mismo.

Solo me queda que pensar... o el conector USB no está bien, o el controlador de mi bafang está capado y no me deja acceder a él.

16 Re: Intentando reprogramar mi bafang... el Sáb Oct 15, 2016 2:57 pm

Hedumaza

avatar
eperezat escribió:

... No ha de ser rs232
 Ya he dado con el problema, Por tu comentario... no podría funcionar en la vida... la culpa es del conector usb-ttl que tengo.
Según la información de la web donde lo he comprado, conector usb-ttl...

Caracteristicas:
 
  Modulo PL2303

     
  • Características del producto:
    Funciona en windows8
    Soporta dos modos de voltaje 3.3v y 5v
    Con 3 LED: LED TXD, RXD LED, LED DE POTENCIA
     
  • Aplicaciones:

RS-232 a USB 
USB a RS-232 
 
Pinuot:
VCC: 3.3V  o 5V 
GND: GND
TXD
RXD

Es un RS-232, ¿ quizás sea por eso que no hace nada ?

17 Re: Intentando reprogramar mi bafang... el Sáb Oct 15, 2016 10:00 pm

eperezat


No es rs232.

Es un rs232 de 5 voltios o de 3voltios en teoria es ok.

Pero eso de 3 o 5 voltios me mosquea.

Yo compre el cable original y corte por el medio y lo conecte a un convertidos de ftdi que siempre me funciono bien.
Y no he tenido ni 1 problema.

Veo que dices que no te carga ningun dato el programa despues de conectar.

Yo creo que a mi aunque no conecte salen unos datos en el programa.
Despues de conectar salen los mismos datos.
Y luego le doy a read y me carga los datos que tengo programados en mi controlador

18 Re: Intentando reprogramar mi bafang... el Dom Oct 16, 2016 12:53 am

Hedumaza

avatar
La aplicación, al ejecutarla, muestra unos datos en los casilleros de la parte izquierda de la pantalla, pero creo que son los que carga por defecto. Cuando pulso sobre connect, no aparece ninguna información en la sección CONTROLLER INFO, todos los apartados permanecen en blanco, y los selectores READ, WRITE, O READ FLASH O WRITE FLASH, permanecen apagados y no se puede pulsar sobre ellos.

19 Re: Intentando reprogramar mi bafang... el Dom Oct 16, 2016 8:56 pm

eperezat


ok entonces esta claro que no conecta.

Algo tiene el cable que no esta bien. El soft si lo has probado en varios pc no creo que sea.

20 Re: Intentando reprogramar mi bafang... el Lun Oct 17, 2016 5:53 am

Hedumaza

avatar
eperezat escribió:ok entonces esta claro que no conecta.

Algo tiene el cable que no esta bien. El soft si lo has probado en varios pc no creo que sea.
¿ Pudiera ser el tipo de cables que he usado ?, como ya he comentado utilicé los de una cpu vieja que tenía, los finitos que van desde los conectores ( usb, audio, etc... ) del frontal, a la placa base.
Desmonté las fundas negras que llevan ( son rectangulares y de plástico duro ), y estraje los terminales factos que llevaba dentro, como eran un poquillo más anchos que los pin del conector verde del controlador, con unos alicates los apreté un poquillo más, de tal manera que entraban justos. Los aislé con cinta aislante, salvo los que puenteaban el PL y P+. Me aseguré de que no pudiesen cortocircuitarse, la prueba es que, tras todos los intentos fallidos, conectas la pantalla y el motor funciona a la perfección.
Aún hoy tengo serias dudas sobre si realmente el culpable fue el conversor USB-TTL, pues creo que es el mismo modelo que han usado en el foro americano para reprogramar el bafang, de hecho, busqué uno con el chip PL-2303-HX precisamente porque eran el que usaban para la reprogramación... y a ellos les funcionó.
El motor, tras conectar los cables, incluso ejecutándose la aplicación, funcionaba, el piloto rojo del sensor de velocidad siempre estaba encendido miesntras intentaba, si éxito, que el ordenador se comunicara con el controlador, de hecho, en varias ocasiones probé a hacer girar el motor... porque eran tantas las dudas que tenía en esos momentos que ya no sabía que hace... al girar los pedales, el motor se ponía en marcha y hacía girar la rueda... todo esto con los cables conectados entre el conector verde del controlador y el conversor usb-ttl conectado al equipo y con la aplicación ejecutándose...
He encontrado un cable en una web italina, pero descarto comprarlo ahí, sale por un riñon, entre lo que piden pòr el cable 43 € ( este es el cable ), más los gastos de envio... y creo que el precio es sin iva... sale por unos 60 y pico pavos... vamos, que es una pasta para un puñetero cablecito... si se dijera que no me queda más remedio...
De momento, a ver si puedo, de una puñetera vez, comprar la bici, que tenía proyectado comprarla para mediados de mes... y entre unas cosas y otras no puedo.... joer, cuando uno dice de comprar algo siempre salen gastos imprevistos que te trastocan los planes...



Última edición por Sebibike el Lun Oct 17, 2016 9:04 am, editado 1 vez (Razón : A ver)

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.